Let's Encrypt

Let's Encrypt Certificate Expiration

How the let's encrypt certificate expiration may impact your subscribers

If you weren't aware, yesterday an older,widely-used root certificate issued by Let’s Encrypt expired. This expiration has affected users of older devices and software that do not automatically update their certificates. These users may now see security warnings when accessing millions of websites and applications.

Devices likely to be impacted include:

  • Android below v2.3.6
  • iPhone iOS 9 and below
  • Nintendo 3DS
  • Windows XP prior to SP3
  • Windows Live Mail (client)
  • PS3 Game Console
  • PS4 Game Console with firmware below 5.00

If your subscribers use one of these older devices or software versions, it's possible they will be impacted by this certificate expiration. The recommended solution is to update to the most recent firmware, operating system, or version. This solution may not be available for some older, end-of-life devices and software.

We've crafted the following message for you to help your subscribers understand the issue, the root cause, and the steps they can take to address it.

“IMPORTANT NOTICE: If you use an older device or software product, you may be seeing security warnings when you open some websites or apps. Yesterday, a certificate (which is kind of like a passport for the internet) expired that was used to ensure secure communications among millions of devices and services. Devices and software that have not been updated since before 2017 may be affected.

The solution is to update to the latest version of your operating system or software, as many older devices do not automatically update their certificates. You can read more about this issue at https://techcrunch.com/2021/09/21/lets-encrypt-root-expiry.

Please feel free to customize this message in any way for use on social media, via direct email messaging, in customer service calls, and any other methods you use to communicate with your subscribers.